Færdiggjort

Mikrotik script generator

I am a co owner of a Wireless ISP.

I need a script generator to write two Mikrotik NAT rules in the following format for each set of customer data, and save the output as a .txt file ready to be copied & pasted it into the router command line interface.

the 'srcnat and 'dstnat' scripts for each customer should be together, not all srcnat then all dstnats for example.

Example of output required for each set of customer data

/ip firewall nat

add action=netmap chain=srcnat comment="CustomerNumber" src-address=

[login to view URL] to-addresses=[login to view URL]

add action=netmap chain=dstnat comment="CustomerNumber" dst-address=

[login to view URL] to-addresses=[login to view URL]

I would have a list of customer numbers, customer IP address and new static public IP

There several hundred in total I would like to be able to enter from 1 set of data at least 100 sets at one time.

I would like to be able to paste these lists into a simple executable windows program and have it output in ascii text form a script ready to paste into the CLI interface of the mikrotik router.

The rules should output in pair, i.e.

Example list:

"customername"

206-Fred Bloggs, Anytown [login to view URL]

520-Sean Smith, BallyDuff Woods [login to view URL]

223 - Pat Murphy, Kerry [login to view URL]

140-Mary Flaherty, Tralee [login to view URL]

658-Michael Kennedy - PortLaoise [login to view URL]

452 - Joan O'Mahony, Kilmacow [login to view URL]

759 - John & Maria Kelly, Dublin [login to view URL]

Public IP's

[login to view URL]

[login to view URL]

[login to view URL]

[login to view URL]

[login to view URL]

[login to view URL]

[login to view URL]

Evner: Linux, Netværksadministrator, PHP, Shell Script, Software Arkitektur

Se mere: flash countdown script generator, script generator pedigree free, google maps api script generator marker, mikrotik firewall rules script, useful mikrotik scripts, mikrotik scripts download, mikrotik script editor, mikrotik address list script, mikrotik run script, mikrotik qos script generator, mikrotik import address list, countdown script generator, website countdown script generator download myspace, googlemap script generator, code php script generator, script generator fonts, script generator banner php, auction script generator, premium script generator

Om arbejdsgiveren:
( 0 bedømmelser ) Waterford, Ireland

Projekt ID: #18589554

Tildelt til:

apiwatk

me experience in mikrotik script. me have prototype tool for mikrotik Script generator to mikrotik. we have skill on web PHP , c# .NET, Network , Router-OS will me support you as soon Thank Apiwat K.

€30 EUR på 1 dag
(3 bedømmelser)
2.3
emely001

Hello, Previosly, I worked with embedded Linux ( OpenWRT, DD-WRT, RouterOs, Tomato), and various toolchains uClib-NG, uClib, OpenWRT SDK, Android NDK. I like very much the development of micro-controllers, so I Flere

€88 EUR in 3 dage
(1 bedømmelse)
0.0

11 freelancere byder i gennemsnit €233 på dette job

techsoftpk

Dear sir, I have worked with mikrotik scripts in past. I have 3+ year experience in script development. Thanks

€294 EUR in 10 dage
(95 bedømmelser)
6.6
AdhamSoft

[[ Save time by dealing with us ]] This link is a system for Bitcoin Wallet [login to view URL] Admin [login to view URL] Click link as showing what I did I can show more samples Flere

€220 EUR in 3 dage
(50 bedømmelser)
6.0
ianoc

Hi there, I was invited to bid on your project by the project recruiter Matthew and I would be glad to help you out with this job in writing a shell script that would create the given output (as you've shown in the Flere

€300 EUR in 3 dage
(46 bedømmelser)
6.0
etuannv

Hi there, I am interested in your project. I am a also network administrator. I manage Juniper Srx firewall. I think I can do you project.I have 4+ years experience at Web scraping. If you'd like to view my previous w Flere

€398 EUR in 3 dage
(44 bedømmelser)
5.8
MNetw

I can do your work perfectly ,actually I have made full systems for mikrotik like hotspot system with radius authentication in cloud and I can do your work

€244 EUR in 3 dage
(1 bedømmelse)
3.9
loftyara

Hi. I suggest you make a program in python. This will not limit its complexity and flexibility and will allow it to run on any prepared platform. I know MikroTik very well. Many years. Probably ~ 1000 configured devic Flere

€250 EUR in 7 dage
(5 bedømmelser)
3.3
mspratt249

I can do this for you, i can write the script to take the input list and generate the nat rule list for the microtik let me know i'm a linux / unix programm i also have lots of wisp experience.

€155 EUR in 3 dage
(1 bedømmelse)
2.8
Stanisljevic

My suggestion will be to go with python, it's best language solution for all systems. I can suggest even better solution to directly connect to mikrotik and send command and not to use copy, paste. I have also lots Flere

€250 EUR in 14 dage
(1 bedømmelse)
1.3
aliimani

Given my resume which is available in my profile, I have a great experience in this regard. . . . . .

€333 EUR in 3 dage
(0 bedømmelser)
0.0